System Requirements

PlaceU™ has been tested with the following browsers:

Mozilla® Firefox®, version 39 or later
Windows®, macOS™/OS X®, Linux®
Google® Chrome™, version 44 or later
Windows, macOS/OS X
Apple® Safari®, version 7 or later
macOS/OS X
Important: Internet Explorer® / Microsoft® Edge is currently not recommended for use with PlaceU.